preload button hover image:
HomeSearchRankingsStatisticsAboutContact
Current Time: Mar 24, 2017, 03:02:36 am
 Dwarf Fortress File Depot » Game Releases » MacNewbie Pack 0.9.18 w/ DF 40.24
      
Registration is not required to download. However, it will allow you to vote, comment, and upload. Forgot your password?
File Listing: MacNewbie Pack 0.9.18 w/ DF 40.24
Last Updated: Nov 29, 2015, 02:48:50 am
First Created: Aug 21, 2013, 11:29:23 am
File version: 0.9.18
For DF version: 0.40.24
Downloads: 5,729 (27,720) Size: 140.37 MB
Views: 19,057 (68,574) Type: DMG
Home:  Forum
Rating (3 votes): 5.0 / 5.0
Description
MacNewbie Pack v0.9.18 - with DFhack-0.40.24-r5 + TWBT

Powered by PyLNP.
Changelog

IMPORTANT

If the launcher can't update your savegames, and your encounter graphical glitches like this, the problem is due to the install logging feature of the launcher. In short, save games now store the installed raw configuration, and without this config file the launcher will ignore these older saves.
To fix this:
  1. Install your desired graphics
  2. Open finder and navigate to Dwarf Fortress/raws, select 'installed_raws.txt'
  3. Copy this configuration file into your save folder's raw directory.
  4. Press the 'Update Savegames' button in the launcher to finalize the process.

Windows version: PeridexisErrant's Starter Pack.
Linux version: Lazy Newb Pack Installer for Linux
If you are looking for the legacy DF2012 pack click here.
Protect the Toad, a natural resource!
support_large.png

Dropbox mirror:
MacNewbie 0.9.18 - 40.24
MacNewbie 0.9.16a - 40.24
MacNewbie 0.9.15 - 40.23
MacNewbie 0.9.14 - 40.19
MacNewbie 0.9.13 - 40.16
MacNewbie 0.9.12 - 40.15
MacNewbie 0.9.11 - 40.14
MacNewbie 0.9.10a - 40.13
Raw Data: JSON / Text
Checksum / Hash
SHA-256: bef808845977a1eb78ba8a862e587f3564de6b71fbe7037105eacbdcbf64285b
IP: logged
Commands
More From This Author
Comments
IP: logged
 MacNewbie Pack 0.9.10a w/ DF 40.13 (v 0.9.10a)  » posted by Taneorox on Oct 22, 2014, 05:56:47 pm
Okay, I am starting to get rather frustrated as I don't quite know where I am going wrong :-x .
I have XQuartz (newest updated version), I have X11 and I have Wine and Wine Bottler, yet the df file will not run. It has it set as just a Unix Executable File, meaning to run with XQuartz, I need to right-click, open with, other, find XQuartz and enable ALL APPLICATIONS to run it. So, it doesn't even register as an XQuartz file. And even when I do that, it just opens X11 and "bash-3.2$" appears and that's it.

Can someone please help, or I'll have to turn to alcoholism :pint:.
IP: logged
 MacNewbie Pack 0.9.10a w/ DF 40.13 (v 0.9.10a)  » posted by fricy on Oct 23, 2014, 01:05:35 am
X11 is not needed anymore, since freetype support library is included, neither is Wine, because everything is native OSX. You either use the launcher to start the game, or a terminal window to run the either ./df or ./df-vanilla, neither of which is an XQuartz file.
You haven't told me which system you have, but it should work on 10.6-10.10, I recommend using at least 10.7.
IP: logged
 Re: MacNewbie Pack 0.9.10a w/ DF 40.13 (v 0.9.10a)  » posted by Taneorox on Oct 23, 2014, 03:58:45 pm
fricy wrote:
X11 is not needed anymore, since freetype support library is included, neither is Wine, because everything is native OSX. You either use the launcher to start the game, or a terminal window to run the either ./df or ./df-vanilla, neither of which is an XQuartz file.
You haven't told me which system you have, but it should work on 10.6-10.10, I recommend using at least 10.7.

Ahh, awesome. So I run the launcher, hit "Play Dwarf Fortress" and nothing happens. I should have stated that, sorry. And are there any alternatives to terminal, as my laptop doesn't have access to it?

I am running Os X 10.8.5 :)
comment last edited by Taneorox on Oct 23, 2014, 03:59:15 pm
IP: logged
 Re: MacNewbie Pack 0.9.10a w/ DF 40.13 (v 0.9.10a)  » posted by Taneorox on Oct 23, 2014, 04:06:12 pm
fricy wrote:
...a terminal window to run the either ./df or ./df-vanilla, neither of which is an XQuartz file.

Nevermind, I installed iTerm and it ran perfectly. Thank you for your time.
IP: logged
 MacNewbie Pack 0.9.18 w/ DF 40.24 (v 0.9.18)  » posted by LegendaryCheaseMaker on Dec 08, 2015, 07:17:30 pm
I have know idea I'm my right mined on how to get this running please help :?:
IP: logged
 MacNewbie Pack 0.9.18 w/ DF 40.24 (v 0.9.18)  » posted by fricy on Dec 09, 2015, 01:19:20 am
1, Mount the .dmg file by double-clicking.
2, Drag and drop the Macnewbie folder to your Applications.
3, Start the Macnewbie launcher to customize and launch DF.
IP: logged
 MacNewbie Pack 0.9.18 w/ DF 40.24 (v 0.9.18)  » posted by LegendaryCheaseMaker on Dec 09, 2015, 05:22:00 am
I've done it before with older updates but now it says waring can't open "image not recognised"
IP: logged
 MacNewbie Pack 0.9.18 w/ DF 40.24 (v 0.9.18)  » posted by LegendaryCheaseMaker on Dec 09, 2015, 05:25:29 am
also thank's for replying

IP: logged
 MacNewbie Pack 0.9.18 w/ DF 40.24 (v 0.9.18)  » posted by fricy on Dec 09, 2015, 06:01:42 am
Please download the pack again, I just verified the archive again, and it's correct.
IP: logged
 MacNewbie Pack 0.9.18 w/ DF 40.24 (v 0.9.18)  » posted by JanDraak on Feb 06, 2017, 05:42:44 am
Is this receiving an update any time soon?
HomeSearchRankingsStatisticsAboutContact

Website © 2017 FenriSoft. The core site script is PHCDownload (© 2005-2017).
Hosted by Linode.