preload button hover image:
HomeSearchRankingsStatisticsAboutContact
Current Time: Aug 13, 2020, 03:29:04 pm
 Dwarf Fortress File Depot » Game Releases » LinuxLNP 0.43.05 (x64 only) FINAL
      
Registration is not required to download. However, it will allow you to vote, comment, and upload. Forgot your password?
File Listing: LinuxLNP 0.43.05 (x64 only) FINAL
Last Updated: Nov 26, 2017, 02:34:22 pm
First Created: Mar 13, 2017, 11:50:59 am
File version: 0.43.05-r07
For DF version: 0.43.05
Downloads: 5,740 (16,131) Size: 130.99 MB
Views: 14,569 (29,478) Type: GZ
Home:  Bay 12 Forum Post
Rating (2 votes): 5.0 / 5.0
Description
To Run: Simply execute the included startlnp script.

If you like the work I've put into assembling this pack, please feel free to head over to my Patreon page and buy me a coffee. Or a beer. Or a sammich. I'm really not picky.

LNP IMPORT TIPS
When first launching a new version of the LNP, you'll be asked if you want to import files from a previous installation. If you select yes, open the previous version's df_linux folder in the file chooser dialog, then click ok. Selecting the LNP folder or the root of the pack will cause the import to fail. The import process will grab your DF saves, SoundSense and/or SoundCense sounds, gamelog, and dfhack history from the previous version.

Major changes over previous revision:
  • Updated PyLNP to 0.13
  • Updated DFHack to v0.43.05-r3.1
  • Updated Armok Vision to v0.18.0
  • Updated Legends Browser to v1.14
  • Updated TWBT to 6.22
  • Updated Dwarf Therapist to 38.1.0

Minor changes over previous revision:
  • Added custom stocksettings to the list of items PyLNP can import from previous versions

Utilities included:
  • PyLNP 0.13
  • DF 0.43.05 x64
  • DFHack 0.43.05-r3.1
  • Dwarf Therapist 38.1.0 (built with Qt5.5.1)
  • TWBT 6.22
  • Soundsense r2016-1 (you'll need to download the sound files yourself from within the application)
  • SoundCenSe GTK 1.4.2 (A c# audio engine for Dwarf Fortress based on Zweistein's SoundSense) (*Requires Mono, go here for install instructions*)
  • Armok Vision 0.18.0
  • Legends Browser 1.14 (*Requires Java 8*)
  • DF Announcement Filter

Graphics packs included:
  • Afro
  • AutoReiv
  • CLA
  • GemSet
  • IronHand
  • Jolly Bastion
  • Mayday
  • Obsidian
  • Phoebus
  • Rally Ho
  • Spacefox
  • Taffer
  • Tergel
  • Wanderlust
Raw Data: JSON / Text
Checksum / Hash
SHA-256: 2d4b371e4c34fda6ccb96e3f0011271901d84adfb92c893a7671e2e015b6310d
IP: logged
Commands
More From This Author
Comments
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by gabix on Mar 17, 2017, 12:30:58 pm
Hi! and first of all, THANKS!

In any case, I'm stupid :oops: I'm on Mint 18 x64 cinnamon, and can't get past the console config thinghy.
I downloaded, and tar -xzf 'd the file to a folder.
In my SO, If I go to a terminal and type gnome-terminal I get a new console opened easily, so after running pylnp I select the option GNOME and leave the custom command textbox blank, that results in DF not launching and returning this:
Code:
~/Juegos/LinuxLNP-0.43.05-rc1 $ sh startlnp startlnp: 35: startlnp: xterm: not found nohup: ignoring input and appending output to 'nohup.out' nohup: failed to run command 'gnome-terminal'$'\n': No such file or directory

I also tried to select custom command, and type gnome-terminal on the textbox, that returns a Test failed: Unknown error.

If I just go and run df everything appears to work, but I WANT dfhack!
Code:
~/Juegos/LinuxLNP-0.43.05-rc1/df_linux $ sh df Sound devices available: OpenAL Soft Picking OpenAL Soft. If your desired device was missing, make sure you have the appropriate 32-bit libraries installed. If you wanted a different device, configure ~/.openalrc appropriately. Perfect OpenAL context attributes GET Loading bindings from data/init/interface.txt New window size: 1280x400 Font size: 16x16 Resizing grid to 80x25 Resizing font to 16x16 Resetting textures Resizing font to 16x16 Resizing font to 16x16

I'm sure the key is this
Code:
startlnp: 35: startlnp: xterm: not found
but... how do I solve it?

Thanks in advance,
gabix.

installing xterm and selecting it from the list solved it! :hammer:
comment last edited by gabix on Mar 30, 2017, 11:51:02 am
IP: logged
 Re: LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by Enay on Mar 22, 2017, 07:55:52 am
gabix wrote:

I'm sure the key is this
Code:
startlnp: 35: startlnp: xterm: not found
but... how do I solve it?


Should be as simple as downloading xterm from your distro's package manager (apt-get, yum, etc).
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by skull42 on Mar 28, 2017, 02:20:52 pm
Code:
symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightToOpenType

I think it's related to the fontconfig package (too recent ?).

thank you anyway!

EDIT: for some reasons I downgrade from 17.04 beta2 to kubuntu 14.04.1 and everything works fine now!
comment last edited by skull42 on Mar 31, 2017, 01:56:10 pm
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by GimliManitoba on Mar 31, 2017, 08:28:45 pm
Hello. I DL'd the tarball and decompressed it. Changed dir to LNP, but I do not see any file called startlnp:

LNP$ ls
about/ defaults/ extras/ keybinds/ tilesets/ utilities/
colors/ embarks/ graphics/ PyLNP.json travis/


Not does find, find any such file. Can anyone help?
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by fuzzyhorns on Apr 03, 2017, 05:56:20 pm
Like the others, I want to start with a thank you: I love DF and was worried I'd give up the convenience of LNP when I switched to Ubuntu.

I am experiencing an issue that seems to prevent playing though:
Code:
./startlnp ERROR: Unable to read current colors Traceback (most recent call last): File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.colors", line 44, in get_colors File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.colors", line 44, in <genexpr> TypeError: int() argument must be a string or a number, not 'NoneType' nohup: ignoring input and appending output to 'nohup.out' ^C # below is prob not relevant but here for completeness Traceback (most recent call last): File "<string>", line 12, in <module> File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/core.lnp", line 126, in __init__ File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/tkgui.tkgui", line 257, in start File "/home/michael/Desktop/df/python_lnp/build/lnp/out00-PYZ.pyz/Tkinter", line 1121, in mainloop KeyboardInterrupt

Looks like it might be related to https://bitbucket.org/Pidgeot/python-lnp/issues/127/pylnp-for-linux-errors-out-trying-to? I can try to build PyLNP from source and see if that fixes it?

I'm on Ubuntu 16.10 and use i3 as my window manager. I don't think I have anything else particularly unique with my setup, but if you let me know any diagnostics I can run for you I'm happy to do so. (I'm a dev IRL.)
comment last edited by fuzzyhorns on Apr 03, 2017, 06:17:03 pm
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by fuzzyhorns on Apr 03, 2017, 08:17:33 pm
I tried running just vanilla df_linux and found it failed. So I made sure I had everything it might depend on (see below) and it worked! The colors warning was a red herring in my case. :) Leaving my original comment in case another person encounters it!
Code:
sudo apt-get install libsdl1.2debian libsdl-image1.2 libsdl-ttf2.0-0
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by opcode on Apr 05, 2017, 11:23:53 am
Dwarf therapist wont work for me :-(

Starting it from the launcher it generates the message that $_DT_BINARY in the script is set incorrect.
I've checked it and the path seems to be correct and the executable flag is set but the bin file is corrupted and the makefile in the directory is hard coded for a person named scott (DT creator? :-) ).
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by zizotex on Apr 16, 2017, 06:35:20 pm
Well I have the same problem like the others.
Code:
nohup: ignoring input and appending output to 'nohup.out'

Before that it finds all Terminals (Urxvt, xterm, i3 and custom commands) (with debugging info enabled)

I used a custom terminal with
Code:
xterm -e $

and the test ist actually successful. When I chose custom terminal, entered this the same errors come up

Edit:
I narrowed it down a bit. The Problem is when I enable TWBT.
i can start the game normally with 2d or standard Print Mode and dfhack enabled.
I'm a little more confused now tbh, Still no other messages from the debug output or anything in the hohup.out
comment last edited by zizotex on Apr 16, 2017, 06:56:57 pm
IP: logged
 LinuxLNP 0.43.05-rc1 (x64 only) (v 0.43.05-rc1)  » posted by lagordon on May 11, 2017, 07:40:16 pm
I'm running Ubuntu 17.04 on an AMD64 architecture. If I run dfhack directly it works, but when I run from PyLNP I get the following output on the terminal and dwarf fortress does not run:
Code:
[distro_fixes] [INFO] Checking whether any distro specific fixes are required... [distro_fixes] [INFO] OS: ubuntu [distro_fixes] [INFO] ARCH: x86_64 [distro_fixes] [INFO] VER: 17.04 [distro_fixes] [INFO] DF_ARCH: 64-bit [distro_fixes] [INFO] DF_BIN_LOCATION: /home/larry/df/df_linux/libs/Dwarf_Fortress [distro_fixes] [INFO] PRELOAD_LIB: [distro_fixes] [INFO] LD_LIBRARY_PATH: /tmp/_MEIgFfwdK [distro_fixes] [INFO] Done ./libs/Dwarf_Fortress: /tmp/_MEIgFfwdK/libncursesw.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libcaca.so.0) ./libs/Dwarf_Fortress: /tmp/_MEIgFfwdK/libncursesw.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libcaca.so.0) ./libs/Dwarf_Fortress: /tmp/_MEIgFfwdK/libtiff.so.5: no version information available (required by /usr/lib/x86_64-linux-gnu/libSDL_image-1.2.so.0) ./libs/Dwarf_Fortress: symbol lookup error: /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0: undefined symbol: FcWeightToOpenType
IP: logged
 LinuxLNP 0.43.05-r06 (x64 only) (v 0.43.05-r06)  » posted by arteenlace on Jul 24, 2017, 03:17:09 am
openSUSE Tumbleweed x86_64
Code:
kreadconfig: /tmp/_MEId1Wcec/libcrypto.so.1.0.0: no version information available (required by /usr/lib64/libQtNetwork.so.4) kreadconfig: /tmp/_MEId1Wcec/libssl.so.1.0.0: no version information available (required by /usr/lib64/libQtNetwork.so.4) nohup: ignoring input and appending output to 'nohup.out'
IP: logged
 Re: LinuxLNP 0.43.05-r06 (x64 only) (v 0.43.05-r06)  » posted by Enay on Jul 31, 2017, 09:47:14 am
arteenlace wrote:
openSUSE Tumbleweed x86_64
Code:
kreadconfig: /tmp/_MEId1Wcec/libcrypto.so.1.0.0: no version information available (required by /usr/lib64/libQtNetwork.so.4) kreadconfig: /tmp/_MEId1Wcec/libssl.so.1.0.0: no version information available (required by /usr/lib64/libQtNetwork.so.4) nohup: ignoring input and appending output to 'nohup.out'

I've been pretty busy lately, but am building a VM with Tumbleweed in my spare time so I can take a look at this. I'll let you know what I find.
HomeSearchRankingsStatisticsAboutContact

Website © 2020 FenriSoft. The core site script is PHCDownload (© 2005-2020).
Hosted by Linode.